通達信均線指標公式源代碼,{分時寫入五日K線} 通達信指標公式源碼

                                  Q1::{分時寫入五日K線} 通達信指標公式源碼

                                  內容來自用戶:育龍投資

                                  {分時寫入五日K線}{幅圖---名字寫分時引用}O1:REF(O,1);C1:REF(C,1);H1:REF(H,1);L1:REF(L,1);O2:REF(O,2);C2:REF(C,2);H2:REF(H,2);L2:REF(L,2);O3:REF(O,3);C3:REF(C,3);H3:REF(H,3);L3:REF(L,3);O4:REF(O,4);C4:REF(C,4);H4:REF(H,4);L4:REF(L,4);O5:REF(O,5);C5:REF(C,5);H5:REF(H,5);L5:REF(L,5);O6:REF(O,6);C6:REF(C,6);H6:REF(H,6);L6:REF(L,6);
                                  {放到分時主圖代碼最前面}O5:="分時引用.O5#DAY";C5:="分時引用.C5#DAY";H5:="分時引用.H5#DAY";L5:="分時引用.L5#DAY";O4:="分時引用.O4#DAY";C4:="分時引用.C4#DAY";H4:="分時引用.H4#DAY";L4:="分時引用.L4#DAY";O3:="分時引用.O3#DAY";C3:="分時引用.C3#DAY";H3:="分時引用.H3#DAY";L3:="分時引用.L3#DAY";O2:="分時引用.O2#DAY";C2:="分時引用.C2#DAY";H2:="分時引用.H2#DAY";L2:="分時引用.L2#DAY";O1:="分時引用.O1#DAY";C1:="分時引用.C1#DAY";H1:="分時引用.H1#DAY";L1:="分時引用.L1#DAY";O0:=DYNAINFO(4);C0:=DYNAINFO(7);H0:=DYNAINFO(5);L0:=DYNAINFO(6);
                                  HH1:=MAX(H1,H2);HH2:=MAX(H3,H4);HH3:=MAX(MAX(H0,H5),MAX(HH1,HH2));LL1:=MIN(L1,L2);LL2:=MIN(L3,L4);LL3:=MIN(MIN(L0,L5),MIN(LL1,LL2));HL:=999/(HH3-LL3);
                                  C52:=999-((C5-LL3)*HL);H52:=999-((H5-LL3)*HL);L52:=999-((L5-LL3)*HL);O52:=999-((O5-LL3)*HL);C42:=999-((C4-LL3)*HL);H42:=999-((H4-LL3)*HL);L42:=999-((L4-LL3)*HL);O42:=999-((O4-LL3)*HL

                                  Q2::求分時均價線,通達信指標的源碼,

                                  均價:SUM(V*C,0)/SUM(V,0),COLORGREEN,LINICK2;
                                  IF(均價<=REF(均價,1),均價,DRAWNULL),COLORGREEN,LINICK3;
                                  IF(均價>=REF(均價,1),均價,DRAWNULL),COLORYELLOW,LINICK3;
                                  DRAWTEXT(CURRBARSCOUNT=4,均價,'均'),COLORYELLOW,LINICK3;
                                  DRAWNUMBER(CURRBARSCOUNT=2,均價,均價),COLORYELLOW,LINICK3;
                                  簡單一點就是
                                  均價:SUM(V*C,0)/SUM(V,0),COLORGREEN,LINICK2;

                                  Q3::【通達信】均線源碼問題

                                  均線向上就是多頭排列,是不能隨意的,在短期均線多頭向上達到一定程度后中期或長期均線才會呈現多頭排列;
                                  如你所述,參考下面語句:
                                  A1:=MA(CLOSE,20);
                                  A2:=MA(CLOSE,30);
                                  A3:=MA(CLOSE,60);
                                  A4:=MA(CLOSE,120);
                                  CLOSE>A1 AND A1>A2 AND A2>A3 AND A3>A4 AND CLOSE>OPEN;
                                  如若想增加就再繼續編寫語句即可,如:
                                  A1:=MA(CLOSE,20);
                                  A2:=MA(CLOSE,30);
                                  A3:=MA(CLOSE,60);
                                  A4:=MA(CLOSE,120);
                                  A5:=MA(CLOSE,250);
                                  CLOSE>A1 AND A1>A2 AND A2>A3 AND A3>A4 AND A4>A5 AND CLOSE>OPEN;

                                  Q4::通達信均線系統設置代碼公式,謝謝。

                                  那不有現成的ma2,自建公式,引入指標公式ma2,把缺省參數改成3 5 8 10 13 20 30 60,公式名稱改一下,就可以,ma2有10條均線,夠你用的,有顏色.

                                  Q5::炒股要懂K線圖的目錄

                                  卷首語
                                  第一章股票技術分析概述
                                  第一節技術分析的涵義
                                  第一假設是進行技術分析的基礎
                                  第二個假設是進行技術分析最根本、最核心的因素
                                  第三個假設是從人的心理因素方面考慮的
                                  第二節技術分析與基礎分析的區別
                                  第三節技術分析的要素
                                  價和量是市場行為最基本的表現
                                  成交量與價格趨勢的關系
                                  第四節技術分析方法分類
                                  指標派
                                  切線派
                                  形態學派
                                  K線派
                                  波浪派
                                  第五節技術分析方法的應用原則
                                  技術分析必須與基本分析結合起來使用,才能提高準確程度,否則單純的技術分析是不全面的
                                  注意多種技術分析方法的綜合研判,切忌片面地使,某一種技術分析結果
                                  把大周期與小周期的圖形結合起來分析
                                  技術分析應在成熟的市場運用
                                  不要把技術分析結果的偶然性當成必然性
                                  第六節技術分析的缺陷
                                  沒有100%的準確率
                                  市場的操縱行為使技術分析暫時失靈
                                  技術分析的滯后性
                                  第二章掌握技術分析的基本理論判斷股價的漲跌
                                  第一節道氏股價波動理論
                                  道氏理論的基本要點
                                  基本趨勢
                                  次級趨勢
                                  短期變動
                                  道氏理論的其他分析方法
                                  道氏理論的缺陷
                                  第二節波浪理論
                                  波浪理論的四個基本特點
                                  波浪的形態
                                  波浪之間的比例
                                  波浪理論內容的幾個基本的要點
                                  波浪理論的缺陷
                                  第三節隨機漫步理論
                                  第四節股市發展階段與成長周期理論
                                  股市成長階段論
                                  股市周期循環論
                                  第五節信心理論
                                  第六節股票價值理論
                                  第七節證券市場分析論
                                  第八節亞當理論
                                  第九節相反理論
                                  第十節黃金分割率理論
                                  黃金分割率由來
                                  黃金分割率的特點
                                  黃金分割率在投資中的運用
                                  第十一節趨勢理論
                                  概述
                                  支撐線和壓力線
                                  支撐線和壓力線的確認和修正
                                  趨勢線
                                  通道線
                                  扇形線
                                  速度線
                                  費波納奇扇形線和弧形線
                                  線性回歸帶
                                  百分比線
                                  第三章掌握K線理論知識判斷股價的漲跌
                                  第一節K線理論的基本知識
                                  K線陰陽圖形的歷史
                                  K線圖形的制作
                                  K線圖的特性
                                  第二節K線的三種分類
                                  K陽線
                                  K陰線
                                  K十字線
                                  第三節讀懂單日K線圖
                                  長陽線
                                  長陰線
                                  十字線
                                  紡錘線
                                  錘頭線
                                  上吊線
                                  流星線
                                  第四節研判雙日K線的組合
                                  組合線形的畫法
                                  “烏云密布”
                                  “雨過天晴”
                                  多頭吞吃
                                  空頭吞吃
                                  蛇吞象
                                  缺口
                                  功能性缺口
                                  普通缺口
                                  三個缺口
                                  第五節三日K線和多日K線組合的分析
                                  黃昏星
                                  晨星
                                  紅三兵
                                  黑三鴉
                                  上升三部曲
                                  下降三部曲
                                  綜合形態分析和實戰應用介紹
                                  第四章大盤走勢分析
                                  第一節日內走勢圖的含義
                                  大盤指數分時走勢圖
                                  個股分時走勢圖
                                  第二節走勢圖一般分析
                                  開盤定性分析
                                  開盤后30分鐘走勢分析
                                  中午收市前30分鐘
                                  下午13:00開盤走勢
                                  尾盤45分鐘走勢
                                  個股開盤異常走勢
                                  個股盤中異常走勢
                                  個股尾盤異常走勢
                                  第五章掌握必備的技術指標判斷股價的變化
                                  第一節趨勢型-移動平均線MA
                                  移動平均線的特點
                                  計算方法
                                  運用原則
                                  葛蘭碧移動平均線八大買賣法則圖解
                                  第二節趨勢型-振動升降指標ASI
                                  計算公式
                                  運用原則
                                  第三節趨勢型-DMA平均線差
                                  計算公式
                                  應用原則
                                  第四節趨勢型-動向指數DMI
                                  計算方法
                                  運用原則
                                  第五節趨勢型-指數平均數EXPMA
                                  計算公式
                                  運用原則
                                  第六節趨勢型-平滑異同移動平均線MACD
                                  MACD的基本運用方法
                                  計算方法
                                  運用原則
                                  第七節趨勢型-梅斯線MASS
                                  計算公式
                                  運用原則
                                  第八節趨勢型-拋物線轉向sAR
                                  計算方法
                                  運用原則
                                  評價
                                  第九節趨勢型-三重指數平滑移動平均TRIX
                                  計算公式
                                  運用原則
                                  第十節趨勢型-布林線BOLL
                                  第十一節趨勢型-瀑布線
                                  瀑布線原理
                                  瀑布線的應用法則
                                  第十二節趨勢型-佳慶變異率VCI
                                  計算公式
                                  運用原則
                                  第十三節趨勢型-十字過濾線VHF
                                  計算公式
                                  運用原則
                                  第十四節趨勢型-寶塔線TOw
                                  第十五節趨勢型-均量線
                                  計算方式
                                  運用原則
                                  功能分析
                                  第十六節超買超賣型-威廉指標%R
                                  計算公式
                                  運用原則
                                  評價
                                  第十七節超買超賣型-乖離率BIAs
                                  計算公式
                                  運用原則
                                  第十八節超買超賣型—順勢指標CCI
                                  計算公式
                                  運用原則
                                  第十九節超買超賣型-區間震蕩線DPO
                                  計算公式
                                  運用原則
                                  第二十節超買超賣型-隨機指數KDJ
                                  計算公式
                                  運用原則
                                  慢速KD指標SLOWKD
                                  第二十一節超買超賣型-資金流量指標MFI
                                  計算公式
                                  運用原則
                                  第二十二節超買超賣型-動量線MOM
                                  計算公式
                                  運用原則
                                  第二十三節超買超賣型-震蕩量指標OSC
                                  計算公式
                                  第二十四節超買超賣型-心理線PSY
                                  計算公式
                                  運用原則
                                  第二十五節超買超賣型-變動率指標ROC
                                  計算公式
                                  運用原則
                                  第二十六節超買超賣型-相對強弱指數RSI
                                  計算公式
                                  運用原則
                                  第二十七節超買超賣型-終極指標UOS
                                  計算公式
                                  運用原則
                                  第二十八節支撐壓力型-MIKE
                                  計算公式
                                  運用原則
                                  第二十九節支撐壓力型-逆勢操作系統cDP
                                  計算公式
                                  運用原則
                                  第三十節能量型-人氣和意愿指標AR、BR與CR
                                  人氣指標
                                  意愿指標
                                  CR指標
                                  第三十一節能量型-簡易波動指標EMV
                                  計算公式
                                  運用原則
                                  第三十二節能量型-負量指標NVI
                                  計算公式
                                  運用原則
                                  第三十三節能量型-能量潮OBV
                                  計算公式
                                  運用原則
                                  第三十四節能量型-正量指標PVI
                                  計算公式
                                  運用原則
                                  第三十五節能量型-指數點成交值TAPI
                                  計算公式
                                  運用原則
                                  第三十六節能量型-成交量比率VR
                                  計算公式
                                  運用原則
                                  第三十七節能量型-威廉變異離散量WVAD
                                  計算公式
                                  運用原則
                                  第三十八節能量型-佳慶指標CHAIKIN
                                  計算公式
                                  運用原則
                                  第三十九節能量型-成交筆數分析
                                  第四十節能量型-逆時鐘曲線
                                  繪制方法
                                  運用原則
                                  第四十一節股市大勢型-絕對廣量指標ABI
                                  計算公式
                                  運用原則
                                  評價
                                  第四十二節股市大勢型-騰落指數ADL
                                  計算公式
                                  運用原則
                                  研判
                                  第四十三節股市大勢型-漲跌比率ADR
                                  計算公式
                                  運用原則
                                  第四十四節股市大勢型-阿姆氏指標ARMS
                                  計算公式
                                  運用原則
                                  第四十五節股市大勢型-廣量沖力指標BTI
                                  計算公式
                                  運用原則
                                  第四十六節股市大勢型-麥克連指標MCL
                                  計算公式
                                  運用原則
                                  第四十七節股市大勢型-麥氏綜合指標MSI
                                  計算公式
                                  運用原則
                                  第四十八節股市大勢型-超買超賣指標OBOS
                                  計算公式
                                  運用原則
                                  第四十九節股市大勢型-指數平滑廣量指標STTX
                                  計算公式
                                  運用原則

                                  Q6::介紹幾部關于K線圖的書籍

                                  【K線入門圖解教程】 【k線技術分析圖解】 【k線實戰圖解教程】

                                  中文字幕AV